BBR算法需要Linux内核版本大于等于4.9,CentOS 8默认内核版本为4.18,可以不用升级内核,直接开启BBR。

可以使用uanme -r命令查看Linux内核版本。

使用如下命令检查是否已经开启了安装了bbr模块:

lsmod | grep bbr                        # 查看是否安装了bbr模块
sysctl net.ipv4.tcp_congestion_control  # 查看当前使用的阻塞算法

如果未启动bbr,则可以通过下列命令启动:

modprobe tcp_bbr
echo "tcp_bbr" >> /etc/modules-load.d/modules.conf
echo "net.core.default_qdisc=fq" >> /etc/sysctl.conf
echo "net.ipv4.tcp_congestion_control=bbr" >> /etc/sysctl.conf
sysctl -p   # 加载修改后的配置文件

使用命令检测是否开启成功:

lsmod | grep bbr
sysctl net.ipv4.tcp_congestion_control

如需关闭BBR,可以,执行以下命令:

sed -i 'tcp_bbr' /etc/modules-load.d/modules.conf
sed -i '/net.core.default_qdisc=fq/d' /etc/sysctl.conf
sed -i '/net.ipv4.tcp_congestion_control=bbr/d' /etc/sysctl.conf
sysctl -p
reboot              # 重启服务器
modprobe -r tcp_bbr # 卸载BBR模块

检查卸载情况:

lsmod | grep bbr
sysctl net.ipv4.tcp_congestion_control

参考资料:
https://zhuanlan.zhihu.com/p/29295440
https://pc6a.com/2023.html

最后修改日期: 2020年3月23日

作者

0 0 投票数
文章评分
订阅评论
提醒
0 评论
内联反馈
查看所有评论